fix configure options error.
[openwrt/svn-archive/archive.git] / sound / flite / Makefile
index 7161c860414987f82fd7d583ba4d79ef40f6116b..c5f70d99190db02a5a0600b560cc43e66330cf95 100644 (file)
@@ -13,7 +13,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.speech.cs.cmu.edu/flite/packed/flite-1.3/
 PKG_MD5SUM:=ae0aca1cb7b4801f4372f3a75a9e52b5
-PKG_CAT:=zcat
  
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -22,13 +21,17 @@ include $(INCLUDE_DIR)/package.mk
 define Package/flite
   SECTION:=sound
   CATEGORY:=Sound
+  DEPENDS:=@!GCC_VERSION_3_4_6
   TITLE:=Text-to-speech for embedded systems
-  DESCRIPTION:=Festival Lite is a stripped down version of Festival,\\\
-    the well-developed text-to-speech program written in C++.\\\
-    This program is written in C to keep memory usage low.
   URL:=http://www.speech.cs.cmu.edu/flite/index.html
 endef
 
+define Package/flite/description
+Festival Lite is a stripped down version of Festival,
+       the well-developed text-to-speech program written in C++.
+       This program is written in C to keep memory usage low.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -54,15 +57,10 @@ define Build/InstallDev
        mkdir -p $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libflite*.so.* $(1)/usr/lib/
 endef
-       
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/flite/{cst,flite}*.h \
-               $(STAGING_DIR)/usr/lib/libflite*.so.*
-endef
 
 define Package/flite/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/flite $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/flite $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libflite*.so.* $(1)/usr/lib/
 endef