[packages] send: fix more OpenSSL 1.0.0 fallout
[openwrt/svn-archive/archive.git] / sound / ices / Makefile
index d836ee4ec83ebe4e6e22b21edd2e689845065b71..814921d5f62bc30fbfdf15ff25de3c1e687bc661 100644 (file)
@@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ices
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ices/
 PKG_MD5SUM:=0d95ac34d59fed337028d5e7771076d8
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
+PKG_FIXUP:=libtool
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ices
@@ -27,14 +29,14 @@ define Package/ices
 endef
 
 define Package/ices/description
-    ices is a command line source client for Icecast media streaming servers.
-    It began as the successor of the old "shout" utility, and has since gained a
-    lot of useful features.
+  ices is a command line source client for Icecast media streaming servers.
+  It began as the successor of the old "shout" utility, and has since gained a
+  lot of useful features.
 endef
 
 define Package/ices/install
-    $(INSTALL_DIR) $(1)/usr/bin
-    $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 CONFIGURE_ARGS+= \
@@ -43,15 +45,15 @@ CONFIGURE_ARGS+= \
 
 define Build/Configure
     $(call Build/Configure/Default, \
-            LDFLAGS="$(TARGET_LDFLAGS) -lz -lm" \
+      LDFLAGS="$(TARGET_LDFLAGS) -lz -lm" \
     )
 endef
 
 define Build/Compile
-    $(MAKE) -C $(PKG_BUILD_DIR) \
-    $(TARGET_CONFIGURE_OPTS) \
-    CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-    LDFLAGS="$(TARGET_LDFLAGS) -lz -lm"
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+         $(TARGET_CONFIGURE_OPTS) \
+         CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+         LDFLAGS="$(TARGET_LDFLAGS) -lz -lm"
 endef
 
 $(eval $(call BuildPackage,ices))