massive Makefile cleanup, add missing 'svn:keywords' property
[openwrt/svn-archive/archive.git] / sound / madplay / Makefile
index 401aad038374586b59d00ebb2d941a0dba1eb9bf..379e22c18d90824da4e765225bc75d1e1afe253c 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,11 +11,11 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=madplay
 PKG_VERSION:=0.15.2b
 PKG_RELEASE:=1
-PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -27,10 +28,11 @@ define Package/madplay
   CATEGORY:=Sound
   DEPENDS:=+libid3tag +libmad
   TITLE:=MPEG audio player in fixed point
-  DESCRIPTION:=MAD is an MPEG audio decoder. It currently only supports the MPEG 1\\\
-standard, but fully implements all three audio layers (Layer I, Layer II,\\\
-and Layer III, the latter often colloquially known as MP3.).  There is also\\\
-full support for ID3 tags.\\\
+  DESCRIPTION:=\
+       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 \\\
+       standard, but fully implements all three audio layers (Layer I, Layer II, \\\
+       and Layer III, the latter often colloquially known as MP3.).  There is also \\\
+       full support for ID3 tags.
   URL:=http://sourceforge.net/projects/mad
 endef
 
@@ -38,29 +40,27 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --disable-static \
-               --with-gnu-ld \
-               --disable-rpath \
                --disable-debugging \
                --disable-profiling \
                --disable-experimental \
                --without-libiconv-prefix \
                --without-libintl-prefix \
                --without-alsa \
-               --without-esd,LIBS="-lz" \
+               --without-esd \
+               , \
+               LIBS="-lz" \
        )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/madplay/install 
-       install -m0755 -d $(1)/usr/bin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,madplay))