add pwgen package (closes: #1276)
[openwrt/svn-archive/archive.git] / sound / madplay / Makefile
index c446727246b0dd541fedf35f691d925aae1f5583..7886c5dd913fdc8511af9cec37a7dca59e35df3b 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,11 +11,11 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=madplay
 PKG_VERSION:=0.15.2b
 PKG_RELEASE:=1
-PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -27,40 +28,39 @@ define Package/madplay
   CATEGORY:=Sound
   DEPENDS:=+libid3tag +libmad
   TITLE:=MPEG audio player in fixed point
-  DESCRIPTION:=MAD is an MPEG audio decoder. It currently only supports the MPEG 1\\\
-standard, but fully implements all three audio layers (Layer I, Layer II,\\\
-and Layer III, the latter often colloquially known as MP3.).  There is also\\\
-full support for ID3 tags.\\\
+  DESCRIPTION:=\
+       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 \\\
+       standard, but fully implements all three audio layers (Layer I, Layer II, \\\
+       and Layer III, the latter often colloquially known as MP3.).  There is also \\\
+       full support for ID3 tags.
   URL:=http://sourceforge.net/projects/mad
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
---disable-static \
---with-gnu-ld \
---disable-rpath \
---disable-debugging \
---disable-profiling \
---disable-experimental \
---without-libiconv-prefix \
---without-libintl-prefix \
---without-alsa \
---without-esd,LIBS="-lz" \
-ac_cv_linux_vers=2 \
-td_cv_buggygetaddrinfo="no")
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --disable-static \
+               --disable-debugging \
+               --disable-profiling \
+               --disable-experimental \
+               --without-libiconv-prefix \
+               --without-libintl-prefix \
+               --without-alsa \
+               --without-esd \
+               , \
+               LIBS="-lz" \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/madplay/install 
-       install -m0755 -d $(1)/usr/bin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,madplay))