[packages] apr: update to v1.3.9
[openwrt/svn-archive/archive.git] / sound / madplay / Makefile
index 379e22c18d90824da4e765225bc75d1e1afe253c..da1bdec42a2e0c2d5cf76a368101952bd78818d6 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,10 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
 PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,14 +23,16 @@ define Package/madplay
   CATEGORY:=Sound
   DEPENDS:=+libid3tag +libmad
   TITLE:=MPEG audio player in fixed point
-  DESCRIPTION:=\
-       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 \\\
-       standard, but fully implements all three audio layers (Layer I, Layer II, \\\
-       and Layer III, the latter often colloquially known as MP3.).  There is also \\\
-       full support for ID3 tags.
   URL:=http://sourceforge.net/projects/mad
 endef
 
+define Package/madplay/description
+       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 
+       standard, but fully implements all three audio layers (Layer I, Layer II, 
+       and Layer III, the latter often colloquially known as MP3.). There is also 
+       full support for ID3 tags.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -59,8 +56,8 @@ define Build/Compile
 endef
 
 define Package/madplay/install 
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,madplay))