fix aiccu compile
[openwrt/svn-archive/archive.git] / sound / madplay / Makefile
index 7886c5dd913fdc8511af9cec37a7dca59e35df3b..f3cc7167b8e7be2c9d57eba7c9cc731e43488c1a 100644 (file)
@@ -16,10 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
 PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,14 +24,16 @@ define Package/madplay
   CATEGORY:=Sound
   DEPENDS:=+libid3tag +libmad
   TITLE:=MPEG audio player in fixed point
-  DESCRIPTION:=\
-       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 \\\
-       standard, but fully implements all three audio layers (Layer I, Layer II, \\\
-       and Layer III, the latter often colloquially known as MP3.).  There is also \\\
-       full support for ID3 tags.
   URL:=http://sourceforge.net/projects/mad
 endef
 
+define Package/madplay/description
+       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 
+       standard, but fully implements all three audio layers (Layer I, Layer II, 
+       and Layer III, the latter often colloquially known as MP3.). There is also 
+       full support for ID3 tags.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -60,7 +58,7 @@ endef
 
 define Package/madplay/install 
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,madplay))