fix configure options error.
[openwrt/svn-archive/archive.git] / sound / mpc / Makefile
index bf744d05ae4877eea0bb50f949e7519c205326b3..2fd1b243fa3c937fac80fa98b4d132a52044e0cc 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.12.0
-PKG_RELEASE:=1
+PKG_VERSION:=0.12.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
-PKG_MD5SUM:=9ec03c5f3d136a9a58ef665dfb100e52
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=a93a390315aacfec061c8df89fb5e35f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +22,16 @@ define Package/mpc
   SECTION:=sound
   CATEGORY:=Sound
   TITLE:=Music Player Daemon Console Client
-  DESCRIPTION:=\
-       MPD is a music player supporting flac, mp3 and ogg files.\\\
-       It is typically controlled over a network using one of it's many \\\
-       clients including mpc(console), gmpc(gnome), phpmp(php) etc.\\\
-       this is MPC
   URL:=http://www.musicpd.org/
 endef
 
+define Package/mpc/description
+       MPD is a music player supporting flac, mp3 and ogg files.
+       It is typically controlled over a network using one of it's many 
+       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+       this is MPC
+endef
+
 define Build/Configure
 $(call Build/Configure/Default, \
        --disable-iconv \
@@ -50,6 +48,7 @@ endef
 define Package/mpc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/mpc $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/pls-handler.sh $(1)/usr/bin
 endef
 
 $(eval $(call BuildPackage,mpc))