DESCRIPTION:= is obselete
[openwrt/svn-archive/archive.git] / sound / mpd / Makefile
index 5fb9efdf67fe3d037681f0fc2aad0d57de9b2612..10b0ebf7cb01a276ce21d6f417232f5c80ac80fe 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.12.0
+PKG_VERSION:=0.13.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
-PKG_MD5SUM:=65e62cc813f2186dff0f96f164a853f8
+PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
+PKG_MD5SUM:=0b33bdb9d706439949344073e90f812a
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,37 +25,42 @@ include $(INCLUDE_DIR)/package.mk
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +alsa-lib
   TITLE:=Music Player Daemon
-  DESCRIPTION:=\
-       MPD is a music player supporting flac, mp3 and ogg files.\\\
-       It is typically controlled over a network using one of it's many \\\
-       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
   URL:=http://www.musicpd.org/
 endef
 
+define Package/mpd/description
+       MPD is a music player supporting flac, mp3 and ogg files.
+       It is typically controlled over a network using one of it's many 
+       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+endef
+
 define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
+ifndef CONFIG_PACKAGE_kmod-soundcore
+       EXTRA_CONFIG_PARAM:=--disable-alsa
+endif
+
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-alsa \
+               $(EXTRA_CONFIG_PARAM) \
                --disable-shout \
-               --disable-mod \
-               --disable-audiofile \
-               --disable-iconv \
-               --disable-mpc \
-               --disable-aac \
-               --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
-               --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
-               --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-mad-includes="$(STAGING_DIR)/usr/include" \
-               --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-tremor \
-               --with-tremor-includes="$(STAGING_DIR)/usr/include" \
-               --with-tremor-libraries="$(STAGING_DIR)/usr/lib" \
+               --disable-mod \
+               --disable-audiofile \
+               --disable-iconv \
+               --disable-mpc \
+               --disable-aac \
+               --disable-oggvorbis \
+               --disable-oggflac \
+               --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
+               --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
+               --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
+               --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
+               --with-mad-includes="$(STAGING_DIR)/usr/include" \
+               --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
        )
 endef
 
@@ -66,9 +71,9 @@ define Build/Compile
 endef
 
 define Package/mpd/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/doc/mpdconf.example $(1)/etc/mpd.conf
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
 endef