[package] update mpd to 0.15, enabled last.fm and libmms support (#5526)
[openwrt/svn-archive/archive.git] / sound / mpd / Makefile
index 6dee11874c16ecfefa56bc6147c156f256bc1c04..7d59d68aa0bf26f8b9985769b0e35ae8dda4fe75 100644 (file)
@@ -1,61 +1,74 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.12.0
+PKG_VERSION:=0.15
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
-PKG_MD5SUM:=65e62cc813f2186dff0f96f164a853f8
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/musicpd
+PKG_MD5SUM:=2ed93a60bd703ba46d6794e12cfb5f1d
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +glib2 +libmss +libcurl
   TITLE:=Music Player Daemon
-  DESCRIPTION:=\
-       MPD is a music player supporting flac, mp3 and ogg files.\\\
-       It is typically controlled over a network using one of it's many \\\
-       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
   URL:=http://www.musicpd.org/
 endef
 
+define Package/mpd/description
+       MPD is a music player supporting flac, mp3 and ogg files.
+       It is typically controlled over a network using one of it's many
+       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+endef
+
 define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
+ifndef CONFIG_PACKAGE_kmod-sound-core
+       EXTRA_CONFIG_PARAM:=--disable-alsa
+endif
+
+CONFIGURE_VARS += \
+       CURL_LIBS="-L$(STAGING_DIR)/usr/lib -lssl -lcrypto -lcurl" \
+       CURL_CFLAGS="-I$(STAGING_DIR)/usr/include" \
+       ID3TAG_LIBS="$(TARGET_LDFLAGS) -lz -lid3tag" \
+       ID3TAG_CFLAGS="$(TARGET_CPPFLAGS)" \
+       FLAC_LIBS="$(TARGET_LDFLAGS) -lFLAC" \
+       FLAC_CFLAGS="-I$(STAGING_DIR)/usr/include/FLAC" \
+       MAD_LIBS="$(TARGET_LDFLAGS) -lmad" \
+       MAD_CFLAGS="$(TARGET_CPPFLAGS)" \
+       OGGVORBIS_LIBS="$(TARGET_LDLFAGS) -lvorbisidec" \
+       OGGVORBIS_CFLAGS="$(TARGET_CPPFLAGS)" \
+       GLIB_CFLAGS="-I$(STAGING_DIR)/usr/include/glib-2.0 -I$(STAGING_DIR)/usr/lib/glib-2.0/include" \
+       GLIB_LIBS="$(TARGET_LDLFAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib -lintl -L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv -lglib-2.0 -lgthread-2.0 -pthread"
+
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-alsa \
-               --disable-shout \
-               --disable-mod \
+               $(EXTRA_CONFIG_PARAM) \
                --disable-audiofile \
-               --disable-iconv \
                --disable-mpc \
                --disable-aac \
-               --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
-               --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
-               --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-mad-includes="$(STAGING_DIR)/usr/include" \
-               --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-tremor \
-               --with-tremor-includes="$(STAGING_DIR)/usr/include" \
-               --with-tremor-libraries="$(STAGING_DIR)/usr/lib" \
+               --disable-lsr \
+               --disable-ipv6 \
+               --disable-ao \
+               --disable-mvp \
+               --disable-lametest \
+               --disable-lame-encoder \
+               --enable-flac \
+               --enable-lastfm \
+               --enable-mms \
+               --with-tremor="$(STAGING_DIR)/usr/lib" \
        )
 endef
 
@@ -69,7 +82,9 @@ define Package/mpd/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/doc/mpdconf.example $(1)/etc/mpd.conf
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mpd.init $(1)/etc/init.d/mpd
 endef
 
 $(eval $(call BuildPackage,mpd))