Fix alsa to mpd
[openwrt/svn-archive/archive.git] / sound / mpd / Makefile
index 4ae9fbfdc8323337c4fb878bfd12c959720bd19b..9be7a75f34a7e52f4849f42aaa6d43384bfdc44b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007 - 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.13.0
+PKG_VERSION:=0.13.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
-PKG_MD5SUM:=0b33bdb9d706439949344073e90f812a
+PKG_MD5SUM:=3079a76b7ce048d89e2f644b578cd4fe
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +alsa-lib
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread
   TITLE:=Music Player Daemon
   URL:=http://www.musicpd.org/
 endef
@@ -39,21 +39,19 @@ define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
-ifndef CONFIG_PACKAGE_kmod-soundcore
+ifndef CONFIG_PACKAGE_kmod-sound-core
        EXTRA_CONFIG_PARAM:=--disable-alsa
 endif
 
 define Build/Configure
        $(call Build/Configure/Default, \
                $(EXTRA_CONFIG_PARAM) \
-               --disable-shout \
                --disable-mod \
                --disable-audiofile \
                --disable-iconv \
                --disable-mpc \
                --disable-aac \
-               --disable-oggvorbis \
-               --disable-oggflac \
+               --with-tremor \
                --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
                --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
                --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
@@ -74,6 +72,8 @@ define Package/mpd/install
        $(CP) $(PKG_BUILD_DIR)/doc/mpdconf.example $(1)/etc/mpd.conf
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mpd.init $(1)/etc/init.d/mpd
 endef
 
 $(eval $(call BuildPackage,mpd))