Update sox to 14.0.1, soxmix is removed upstream, add libgsm dependency (#3616)
[openwrt/svn-archive/archive.git] / sound / mpd / Makefile
index 592179cde040f05fdaa6d9200b28bd859a5fea06..c9f9c9aa46a893ca6a73190f690e1c4d760d845b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007 - 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,56 +9,53 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.13.0
+PKG_VERSION:=0.13.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
-PKG_MD5SUM:=0b33bdb9d706439949344073e90f812a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=b461896369949ff3cff955692ead9f8b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +alsa-lib
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +libiconv
   TITLE:=Music Player Daemon
-  DESCRIPTION:=\
-       MPD is a music player supporting flac, mp3 and ogg files.\\\
-       It is typically controlled over a network using one of it's many \\\
-       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
   URL:=http://www.musicpd.org/
 endef
 
+define Package/mpd/description
+       MPD is a music player supporting flac, mp3 and ogg files.
+       It is typically controlled over a network using one of it's many
+       clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+endef
+
 define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
-ifndef CONFIG_PACKAGE_kmod-soundcore
+ifndef CONFIG_PACKAGE_kmod-sound-core
        EXTRA_CONFIG_PARAM:=--disable-alsa
 endif
 
 define Build/Configure
        $(call Build/Configure/Default, \
                $(EXTRA_CONFIG_PARAM) \
-               --disable-shout \
                --disable-mod \
                --disable-audiofile \
-               --disable-iconv \
                --disable-mpc \
                --disable-aac \
-               --disable-oggvorbis \
-               --disable-oggflac \
+               --with-tremor \
                --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
                --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
                --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
                --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
                --with-mad-includes="$(STAGING_DIR)/usr/include" \
                --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
+               --with-iconv-includes="$(STAGING_DIR)/usr/lib/libiconv/include" \
+               --with-iconv-libraries="$(STAGING_DIR)/usr/lib/libiconv/lib" \
        )
 endef
 
@@ -72,7 +69,9 @@ define Package/mpd/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/doc/mpdconf.example $(1)/etc/mpd.conf
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mpd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mpd.init $(1)/etc/init.d/mpd
 endef
 
 $(eval $(call BuildPackage,mpd))