remove PKG_CAT from packages
[openwrt/svn-archive/archive.git] / sound / mt-daapd / Makefile
index 0fdbfffdf2b1e5fe60dae24155b0d12c3afa69e4..3f7eeeff0fa3ca6d284880573fab010898d241ca 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mt-daapd
 PKG_MD5SUM:=2e1cdbe6b94ef153e915806f80a28dca
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,9 +26,11 @@ define Package/mt-daapd
   CATEGORY:=Sound
   DEPENDS:=+libgdbm +libhowl +libid3tag
   TITLE:=A multi-threaded DAAP (Digital Audio Access Protocol) daemon
-  DESCRIPTION:=\
+  URL:=http://www.mt-daapd.org/
+endef
+
+define Package/mt-daapd/description
        mt-daapd is a program which acts as an iTunes (DAAP) server for Linux.
-  URL:=http://www.mt-daapd.org
 endef
 
 define Package/mt-daapd/conffiles
@@ -57,15 +58,15 @@ define Build/Compile
 endef
 
 define Package/mt-daapd/install        
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/contrib/mt-daapd.conf $(1)/etc/
-       install -m0644 $(PKG_BUILD_DIR)/contrib/mt-daapd.playlist $(1)/etc/
-       install -d -m0755 $(1)/usr/share
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/contrib/mt-daapd.conf $(1)/etc/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/contrib/mt-daapd.playlist $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/mt-daapd $(1)/usr/share/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mt-daapd $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/mt-daapd.init $(1)/etc/init.d/mt-daapd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mt-daapd.init $(1)/etc/init.d/mt-daapd
 endef
 
 $(eval $(call BuildPackage,mt-daapd))