packages/scmpc: use new service functions
[openwrt/svn-archive/archive.git] / sound / scmpc / Makefile
index 45baa1b7573f21b32631a9a6c2cb823947210460..4013085e035205b6e2de217bba58b4a329bff063 100644 (file)
@@ -1,31 +1,27 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 9349 2007-10-18 18:46:37Z blogic $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scmpc
 PKG_VERSION:=0.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/scmpc
 PKG_MD5SUM:=f42482e4dbf398df92a36d5610b403e5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/scmpc
   SECTION:=sound
   CATEGORY:=Sound
   TITLE:=A MPD client which submits your tracks to Last.Fm
-  DEPENDS:=+libcurl +libdaemon +argtable +confuse
+  DEPENDS:=+libcurl +libdaemon +argtable +confuse +libpthread
   URL:=http://scmpc.berlios.de/
 endef
 
@@ -39,11 +35,14 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --without-libiconv-prefix \
        --without-libintl-prefix \
+
 MAKE_FLAGS += \
        $(TARGET_CONFIGURE_OPTS) \
        $(1) \
 
+TARGET_LDFLAGS += \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Package/scmpc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/scmpc $(1)/usr/bin/