Requirements cleanup
[openwrt/svn-archive/archive.git] / sound / shell-fm / Makefile
index b203d43a84676f6c205255abd5713edd030c0447..04b424c76b6587256a0fe940a517122f44d87013 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shell-fm
 PKG_VERSION:=0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://nex.scrapping.cc/shell-fm/downloads
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/shell-fm
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libmad +openssl +readline +libncurses
+  DEPENDS:=+libmad +libopenssl +libreadline +libncurses
   TITLE:=Console Based Last.FM Radio Player
   DESCRIPTION:=\
        Shell.FM is a console based player for the streams provided \\\
@@ -33,9 +33,13 @@ define Package/shell-fm
   URL:=http://nex.scrapping.cc
 endef
 
+define Package/shell-fm/conffiles
+/etc/shell-fm.rc
+endef
+
 define Build/Configure
        $(PKG_BUILD_DIR)/reconfig
-       $(call Build/Configure/Default)
+       $(call Build/Configure/Default, --disable-ao)
 endef
 
 define Build/Compile
@@ -46,7 +50,17 @@ endef
 
 define Package/shell-fm/install        
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/shell-fm.init $(1)/etc/init.d/shell-fm
 endef
 
 $(eval $(call BuildPackage,shell-fm))
+
+
+$(eval $(call RequireCommand,aclocal, \
+       $(PKG_NAME) requires automake \
+))
+