[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / sound / shell-fm / Makefile
index bc06a813f43a1af61186c5ee68afc49f61950316..9fc12770e660ecbb7dba74cf91a2cdf56a5d2ee8 100644 (file)
@@ -1,30 +1,26 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shell-fm
-PKG_VERSION:=0.2
+PKG_VERSION:=0.5
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://nex.scrapping.cc/shell-fm/downloads
-PKG_MD5SUM:=6ebbcf1af241a92a1237547fc39ca728
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://nex.scrapping.cc/code/shell-fm/downloads/
+PKG_MD5SUM:=a257283b0f7e9173ee1073b88e57c5f6
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shell-fm
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libmad +libopenssl +libreadline +libncurses
+  DEPENDS:=+libao +libmad
   TITLE:=Console Based Last.FM Radio Player
   URL:=http://nex.scrapping.cc
 endef
@@ -39,19 +35,20 @@ define Package/shell-fm/conffiles
 endef
 
 define Build/Configure
-       $(PKG_BUILD_DIR)/reconfig
-       $(call Build/Configure/Default, --disable-ao)
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I./include/ $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS) -lmad -lao" \
                all install
 endef
 
 define Package/shell-fm/install        
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/shell-fm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -59,9 +56,3 @@ define Package/shell-fm/install
 endef
 
 $(eval $(call BuildPackage,shell-fm))
-
-
-$(eval $(call RequireCommand,aclocal, \
-       $(PKG_NAME) requires automake \
-))
-