[packages] apr: update to v1.3.9
[openwrt/svn-archive/archive.git] / sound / shell-fm / Makefile
index ecfe8271a5fa5161d0a03a48919d444a1aa943dc..e1c74840bb38248d547d44dc5e091425b02560be 100644 (file)
@@ -1,65 +1,60 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shell-fm
-PKG_VERSION:=0.2
-PKG_RELEASE:=2
+PKG_VERSION:=0.7
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://nex.scrapping.cc/shell-fm/downloads
-PKG_MD5SUM:=6ebbcf1af241a92a1237547fc39ca728
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/jkramer/shell-fm.git
+PKG_SOURCE_VERSION:=c274aa51b52185b289ac22f0cb95420a1c19868b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shell-fm
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libmad +libopenssl +libreadline +libncurses
+  DEPENDS:=+libao +madplay +libpthread
   TITLE:=Console Based Last.FM Radio Player
-  DESCRIPTION:=\
-       Shell.FM is a console based player for the streams provided \\\
-       by Last.FM for the Linux platform. It's lightweight and easy to use.
   URL:=http://nex.scrapping.cc
 endef
 
+define Package/shell-fm/description
+       Shell.FM is a console based player for the streams provided
+       by Last.FM for the Linux platform. It's lightweight and easy to use.
+endef
+
 define Package/shell-fm/conffiles
 /etc/shell-fm.rc
 endef
 
 define Build/Configure
-       $(PKG_BUILD_DIR)/reconfig
-       $(call Build/Configure/Default, --disable-ao)
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I./include/ $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS) -lmad -lao -lpthread" \
                all install
 endef
 
-define Package/shell-fm/install        
+define Package/shell-fm/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
-       $(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/shell-fm.init $(1)/etc/init.d/shell-fm
 endef
 
 $(eval $(call BuildPackage,shell-fm))
-
-
-$(eval $(call RequireCommand,aclocal, \
-       shell-fm requires automake \
-))
-