[package] update curl to 7.19.5 (#5219)
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index be74758132d0fc0cf2f32c2091fadc8c3711136e..27c12fe0685b80c115fcdd60318a9f75c91ed577 100644 (file)
@@ -1,29 +1,31 @@
 # 
+# Copyright (C) 2008 David Cooper <dave@kupesoft.com>
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
 PKG_VERSION:=14.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sox
 PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+# NOTE: libflac is out of date for 8.09's freeze and can't be compiled in
+
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libgsm
+  DEPENDS:=+libmad +libvorbis +libvorbisidec +libgsm
   TITLE:=Sox is a general purpose sound converter/player/recorder
   URL:=http://sox.sourceforge.net/
 endef
@@ -39,8 +41,8 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
-               , \
-               LIBS="-lnotimpl -lm" \
+               --without-libltdl \
+               --with-ogg \
        )
 endef
 
@@ -48,12 +50,15 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                STAGING_DIR="$(STAGING_DIR)" \
-               all
+               all install
 endef
 
 define Package/sox/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/{play,sox} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{play,rec,sox} $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/{libsfx.so*,libsox.so*} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,sox))
+