add pwgen package (closes: #1276)
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index bab312bc2b239e40d3275ee8a2e30c3b23951432..2ebca469eb5a5d64c17b1701f0616dcde6c7ff51 100644 (file)
@@ -20,12 +20,14 @@ PKG_CAT:=zcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+PKG_BUILD_DEPENDS:=libnotimpl
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libnotimpl
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
   TITLE:=Sox is a general purpose sound converter/player/recorder
   DESCRIPTION:=\
        SoX is a command line utility that can convert various formats\\\
   TITLE:=Sox is a general purpose sound converter/player/recorder
   DESCRIPTION:=\
        SoX is a command line utility that can convert various formats\\\
@@ -39,6 +41,8 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
+               , \
+               LIBS="-lnotimpl -lm" \
        )
 endef
 
        )
 endef
 
@@ -50,7 +54,7 @@ define Build/Compile
 endef
 
 define Package/sox/install
 endef
 
 define Package/sox/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
 endef
 
        $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
 endef