Makefile cleanups, round 3
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index 057f32c53578d932e9b0995ebe1eb82ee01da79b..be74758132d0fc0cf2f32c2091fadc8c3711136e 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
-PKG_VERSION:=12.18.2
+PKG_VERSION:=14.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sox
-PKG_MD5SUM:=ba25e512a6c824d6e56d76767a18af99
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
@@ -27,17 +23,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libgsm
   TITLE:=Sox is a general purpose sound converter/player/recorder
-  DESCRIPTION:=\
-       SoX is a command line utility that can convert various formats\\\
-       of computer audio files in to other formats. It can also apply\\\
-       various effects to these sound files during the conversion.\\\
-       As an added bonus, SoX can play and record audio files on\\\
-       several unix-style platforms.
   URL:=http://sox.sourceforge.net/
 endef
 
+define Package/sox/description
+       SoX is a command line utility that can convert various formats
+       of computer audio files in to other formats. It can also apply
+       various effects to these sound files during the conversion.
+       As an added bonus, SoX can play and record audio files on
+       several unix-style platforms.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
@@ -55,7 +53,7 @@ endef
 
 define Package/sox/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/src/{play,sox} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,sox))