Makefile cleanups, round 3
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index 2ffc94629a6efc60d47c23c5ffbe1566012a7b5d..be74758132d0fc0cf2f32c2091fadc8c3711136e 100644 (file)
@@ -4,38 +4,38 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5329 2006-10-28 22:43:08Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
-PKG_VERSION:=12.18.2
+PKG_VERSION:=14.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sox
-PKG_MD5SUM:=ba25e512a6c824d6e56d76767a18af99
-PKG_CAT:=zcat
+PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libnotimpl
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libgsm
   TITLE:=Sox is a general purpose sound converter/player/recorder
-  DESCRIPTION:=\
-       SoX is a command line utility that can convert various formats\\\
-       of computer audio files in to other formats. It can also apply\\\
-       various effects to these sound files during the conversion.\\\
-       As an added bonus, SoX can play and record audio files on\\\
-       several unix-style platforms.
   URL:=http://sox.sourceforge.net/
 endef
 
+define Package/sox/description
+       SoX is a command line utility that can convert various formats
+       of computer audio files in to other formats. It can also apply
+       various effects to these sound files during the conversion.
+       As an added bonus, SoX can play and record audio files on
+       several unix-style platforms.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
@@ -52,8 +52,8 @@ define Build/Compile
 endef
 
 define Package/sox/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/{play,sox} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,sox))