Okay, so this fixes Sox in 8.09 which has been very broken. This
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index dc374e045c4a4e42e5ef12c14bdade55a4132c8a..bf0d23a2223064ed895902319fe7e3d6695b199f 100644 (file)
@@ -1,4 +1,5 @@
 # 
+# Copyright (C) 2008 David Cooper <dave@kupesoft.com>
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
 PKG_VERSION:=14.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sox
@@ -21,10 +22,12 @@ PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
+# NOTE: libflac is out of date for 8.09's freeze and can't be compiled in
+
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libgsm
+  DEPENDS:=+libmad +libvorbis +libvorbisidec +libgsm
   TITLE:=Sox is a general purpose sound converter/player/recorder
   URL:=http://sox.sourceforge.net/
 endef
@@ -40,6 +43,8 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
+               --without-libltdl \
+               --with-ogg \
                , \
                LIBS="-lnotimpl -lm" \
        )
@@ -49,12 +54,15 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                STAGING_DIR="$(STAGING_DIR)" \
-               all
+               all install
 endef
 
 define Package/sox/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/{play,sox} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{play,rec,sox} $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/{libsfx.so*,libsox.so*} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,sox))
+