sox: cleanup (use PKG_INSTALL, make build more deterministic), make build depending...
[openwrt/svn-archive/archive.git] / sound / sox / Makefile
index 2ebca469eb5a5d64c17b1701f0616dcde6c7ff51..fa12a82c35303bbeec1007207753d7f2355bf70c 100644 (file)
@@ -1,61 +1,74 @@
 # 
+# Copyright (C) 2008 David Cooper <dave@kupesoft.com>
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5329 2006-10-28 22:43:08Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
-PKG_VERSION:=12.18.2
-PKG_RELEASE:=1
+PKG_VERSION:=14.0.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sox
-PKG_MD5SUM:=ba25e512a6c824d6e56d76767a18af99
-PKG_CAT:=zcat
+PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+# NOTE: libflac is out of date for 8.09's freeze and can't be compiled in
+
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
+  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm
   TITLE:=Sox is a general purpose sound converter/player/recorder
-  DESCRIPTION:=\
-       SoX is a command line utility that can convert various formats\\\
-       of computer audio files in to other formats. It can also apply\\\
-       various effects to these sound files during the conversion.\\\
-       As an added bonus, SoX can play and record audio files on\\\
-       several unix-style platforms.
   URL:=http://sox.sourceforge.net/
 endef
 
+define Package/sox/description
+       SoX is a command line utility that can convert various formats
+       of computer audio files in to other formats. It can also apply
+       various effects to these sound files during the conversion.
+       As an added bonus, SoX can play and record audio files on
+       several unix-style platforms.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-external-gsm \
-               , \
-               LIBS="-lnotimpl -lm" \
+               --disable-oss \
+               --enable-alsa \
+               --disable-libao \
+               --without-libltdl \
+               --with-ogg \
+               --without-flac \
+               --without-ffmpeg \
+               --without-amr-wb \
+               --without-amr-nb \
+               --without-samplerate \
+               --without-ladspa \
+               --$(if $(CONFIG_BUILD_PATENTED),with-mad,without-mad) \
+               --$(if $(CONFIG_BUILD_PATENTED),with-lame,without-lame) \
+               --$(if $(CONFIG_BUILD_PATENTED),with-id3tag,without-id3tag) \
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               STAGING_DIR="$(STAGING_DIR)" \
-               all
-endef
-
 define Package/sox/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{play,rec,sox} $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/{libsfx.so*,libsox.so*} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,sox))
+