[packages] streamripper: explicitely disable use of internal libmad (closes: #6974...
[openwrt/svn-archive/archive.git] / sound / streamripper / Makefile
index 5ed45d458cf34711fc8af0cbd2ca7f91cc2d666c..1cd35f433d093aa662bfe34e142547a98e879a98 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,22 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=streamripper
 PKG_VERSION:=1.62.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=1a8353af3c36d56f2d8ee8552f632071
 
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=. tre-0.7.2
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/streamripper
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libmad
+  DEPENDS:=+libmad +libfaad2
   TITLE:=streamripper
   URL:=http://streamripper.sourceforge.net/
 endef
@@ -32,22 +36,13 @@ endef
 
 EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-ogg \
-               --with-included-argv \
-               --without-libiconv-prefix \
-               --with-included-tre \
-               --with-gnu-ld \
-       )
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --without-ogg \
+       --with-included-argv \
+       --without-included-libmad \
+       --without-libiconv-prefix \
+       --with-included-tre \
+       --with-gnu-ld \
 
 define Package/streamripper/install
        $(INSTALL_DIR) $(1)/usr/bin