Reorder profiles, TI Wi-Fi is more common than atheros on adm5120eb
[openwrt/svn-archive/archive.git] / target / Makefile
index 3f97b9a14da72ca3b04075d2b52c6a64d3b7a8f1..1b6cbb54ee1014e6f024f8c8fba6fe1e698fd6a9 100644 (file)
@@ -20,7 +20,7 @@ IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
 download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
 compile: linux-compile image_compile
-install: image_clean linux-install image_install 
+install: linux-install image_install 
 
 ifeq ($(CONFIG_SDK),y)
 install: sdk_install
@@ -51,14 +51,4 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))