rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt/svn-archive/archive.git] / target / imagebuilder / Makefile
index 470d045642dc50c32c0bcbab6f6bf736ded664c7..0cbbfa28353101c18e5e558741fd0147b0c899ee 100644 (file)
@@ -18,13 +18,15 @@ IB_BUILD_DIR:=$(BUILD_DIR)/$(IB_NAME)
 
 all: compile
 
-$(BIN_DIR)/$(IB_NAME).tar.bz2:
+$(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        rm -rf $(IB_BUILD_DIR)
        mkdir -p $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) $(IB_BUILD_DIR)/staging_dir_$(ARCH)/bin $(IB_BUILD_DIR)/target/linux
        $(CP) \
                $(INCLUDE_DIR) $(SCRIPT_DIR) $(PACKAGE_DIR) \
                $(TOPDIR)/rules.mk $(TOPDIR)/.config \
                $(TMP_DIR)/.target.mk \
+               $(TMP_DIR)/.pkginfo \
+               $(TMP_DIR)/.targetinfo \
                ./files/Makefile \
                $(IB_BUILD_DIR)/
        $(CP) $(STAGING_DIR)/bin/* $(IB_BUILD_DIR)/staging_dir_$(ARCH)/bin
@@ -42,5 +44,5 @@ prepare:
 compile: $(BIN_DIR)/$(IB_NAME).tar.bz2
 install: compile
 
-clean:
+clean: FORCE
        rm -rf $(IB_BUILD_DIR) $(BIN_DIR)/$(IB_NAME).tar.bz2