[brcm63xx] include kmod-usb-storage and kmod-ipt-nathelper-extra for SIP connection...
[openwrt/svn-archive/archive.git] / target / imagebuilder / Makefile
index 8a3ac7fed9c6c4b490490542b6ab8a0d52e79d7b..d0b6b88b2e6f6f2d4de448d5a54a38577a9ad4ca 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6070 2007-01-10 21:21:59Z nbd $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -25,12 +24,13 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        rm -rf $(PKG_BUILD_DIR)
        mkdir -p $(IB_KDIR) $(PKG_BUILD_DIR)/staging_dir/host $(PKG_BUILD_DIR)/target
        $(CP) \
-               $(INCLUDE_DIR) $(SCRIPT_DIR) $(PACKAGE_DIR) \
+               $(INCLUDE_DIR) $(SCRIPT_DIR) \
                $(TOPDIR)/rules.mk $(TOPDIR)/.config \
                ./files/Makefile \
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
+       $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(TOOLCHAIN_DIR)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(STAGING_DIR_HOST)/bin/* $(PKG_BUILD_DIR)/staging_dir/host/bin/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/