[kernel] fix kexec for mips, patch from Adrian Byszuk (#7115)
[openwrt/svn-archive/archive.git] / target / imagebuilder / files / Makefile
index e003a32f2d58154d7048f70a7cfece77ae37b9eb..49fd6db949c0b44b862845b14a407cdb19c603f4 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,6 +24,9 @@ include rules.mk
 include $(INCLUDE_DIR)/debug.mk
 include $(INCLUDE_DIR)/depends.mk
 
+include $(INCLUDE_DIR)/version.mk
+export REVISION
+
 define Helptext
 Available Commands:
        help:   This help text
@@ -81,17 +84,12 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
        @echo 'dest root /' > $@
        @echo 'src packages file:$(PACKAGE_DIR)' >> $@
 
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
 
 image:
-       if [ -z "$($(PROFILE)_NAME)" ]; then \
-               echo Profile $(PROFILE) not found.; \
-               echo 'Use "make info" to get a list of available target profiles'; \
-               false; \
-       fi
-       echo 'Building images for $(BOARD) - $($(PROFILE)_NAME)'
+       echo 'Building images for $(BOARD)$(if $($(PROFILE)_NAME), - $($(PROFILE)_NAME))'
        echo 'Packages: $(BUILD_PACKAGES)'
        echo
        rm -rf $(TARGET_DIR)