ignore profiles with custom kernel configs in the image builder itself
[openwrt/svn-archive/archive.git] / target / imagebuilder / files / Makefile
index b36e2f2e31235308813a0ed781b8099a818b8ed5..8b386a33c6c6e49f89bb4f7a5569e66f1db4d445 100644 (file)
@@ -34,6 +34,7 @@ IPKG:= \
 define Profile/Default
   ID:=
   NAME:=
+  KCONFIG:=
   PACKAGES:=
 endef
 
@@ -46,8 +47,10 @@ define AddProfile
     endif
        $(ID)_NAME:=$(NAME)
        $(ID)_PACKAGES:=$(PACKAGES)
-    PROFILE_LIST += \
+    ifneq ($(KCONFIG),)
+      PROFILE_LIST += \
                echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
+    endif
   endif
 endef