package/index: filter out the libc package from the index
[openwrt/svn-archive/archive.git] / target / imagebuilder / files / Makefile
index bcdcf03de5ca895eb7c27a5b5738ed7c7410325c..b0d0698acdc5370ab48e9e25dc858643d060bd4f 100644 (file)
@@ -10,7 +10,7 @@ TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
 export TOPDIR LC_ALL LANG
-export KBUILD_VERBOSE=99
+export OPENWRT_VERBOSE=s
 all: help
 
 include $(TOPDIR)/include/host.mk
@@ -38,10 +38,11 @@ Building images:
        By default 'make image' will create an image with the default
        target profile and package set. You can use the following parameters
        to change that:
-       
+
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
+       make image BIN_DIR="<path>" # alternative output directory for the images
 
 endef
 $(eval $(call shexport,Helptext))
@@ -58,9 +59,15 @@ OPKG:= \
   IPKG_CONF_DIR="$(TOPDIR)/tmp" \
   IPKG_OFFLINE_ROOT="$(TARGET_DIR)" \
   $(STAGING_DIR_HOST)/bin/opkg \
-       -f $(TOPDIR)/tmp/opkg.conf \
+       -f $(TOPDIR)/repositories.conf \
        --force-depends \
-       --force-overwrite
+       --force-overwrite \
+       --force-postinstall \
+       --cache $(TOPDIR)/dl \
+       --offline-root $(TARGET_DIR) \
+       --add-dest root:/ \
+       --add-arch all:100 \
+       --add-arch $(ARCH_PACKAGES):200
 
 define Profile
   $(eval $(call Profile/Default))
@@ -82,22 +89,10 @@ _call_info: FORCE
        echo 'Available Profiles:'
        echo; $(PROFILE_LIST)
 
-$(TOPDIR)/tmp/opkg.conf: FORCE
-       @mkdir -p $(TOPDIR)/tmp
-       @mkdir -p $(TARGET_DIR)/tmp
-       @echo 'dest root /' > $@
-       @echo 'src packages file:$(PACKAGE_DIR)' >> $@
-       @echo 'arch all 100' >> $@
-ifneq ($(CONFIG_TARGET_adm5120),y)
-       @echo 'arch $(BOARD) 200' >> $@
-else
-       @echo 'arch $(BOARD)_$(ARCH) 200' >> $@
-endif
-       @echo 'option offline_root $(TARGET_DIR)' >> $@
-
 BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(USER_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
+PACKAGES:=
 
 _call_image:
        echo 'Building images for $(BOARD)$(if $($(USER_PROFILE)_NAME), - $($(USER_PROFILE)_NAME))'
@@ -105,17 +100,24 @@ _call_image:
        echo
        rm -rf $(TARGET_DIR)
        mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR)
-       $(MAKE) package_index
+       if [ ! -f "$(PACKAGE_DIR)/Packages" ] || [ ! -f "$(PACKAGE_DIR)/Packages.gz" ] || [ "`find $(PACKAGE_DIR) -cnewer $(PACKAGE_DIR)/Packages.gz`" ]; then \
+               echo "Package list missing or not up-to-date, generating it.";\
+               $(MAKE) package_index; \
+       else \
+               mkdir -p $(TARGET_DIR)/tmp; \
+               $(OPKG) update; \
+       fi
        $(MAKE) package_install
 ifneq ($(USER_FILES),)
        $(MAKE) copy_files
 endif
        $(MAKE) package_postinst
        $(MAKE) build_image
-       
-package_index: $(TOPDIR)/tmp/opkg.conf FORCE
+
+package_index: FORCE
        @echo
        @echo Building package index...
+       @mkdir -p $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR)/tmp
        (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
                gzip -9c Packages > Packages.gz \
        ) >/dev/null 2>/dev/null
@@ -124,7 +126,10 @@ package_index: $(TOPDIR)/tmp/opkg.conf FORCE
 package_install: FORCE
        @echo
        @echo Installing packages...
+       $(OPKG) install $(PACKAGE_DIR)/libc_*.ipk
+       $(OPKG) install $(PACKAGE_DIR)/kernel_*.ipk
        $(OPKG) install $(BUILD_PACKAGES)
+       rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*
 
 copy_files: FORCE
        @echo
@@ -144,14 +149,16 @@ package_postinst: FORCE
                        IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
                done || true; \
        )
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
 
 build_image: FORCE
        @echo
        @echo Building images...
-       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1
-       
+       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 \
+               $(if $(USER_PROFILE),PROFILE="$(USER_PROFILE)")
+
 clean:
-       rm -rf tmp $(TARGET_DIR) $(BIN_DIR)
+       rm -rf $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR) $(BIN_DIR)
 
 
 info:
@@ -162,7 +169,8 @@ image:
        $(MAKE) _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
-               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)"))
+               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
+               $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)"))
 
 .SILENT: help info image