Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
[openwrt/svn-archive/archive.git] / target / linux / Makefile
index 275085448f5d8496dc96a01b4a71937c5bcb59f3..e1248691501fe0df3431c2e1096de435e543f00b 100644 (file)
@@ -7,23 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+clean download prepare compile install menuconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-refresh:
-       $(MAKE) -C $(BOARD)-$(KERNEL) refresh
-
-menuconfig:
-       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean