bcm47xx: Remove kernel checks from image Makefile
[openwrt/svn-archive/archive.git] / target / linux / Makefile
index 5a1ca723a6305338304e4b7227eb41297b09c237..f7bbdffbf831654ca8617277e5fd7aeb8959f416 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-clean download prepare compile install menuconfig oldconfig update refresh: FORCE
-       $(MAKE) -C $(BOARD)-$(KERNEL) $@
+export TARGET_BUILD=1
 
+prereq clean download prepare compile install menuconfig nconfig oldconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@