bcm47xx: Remove kernel checks from image Makefile
[openwrt/svn-archive/archive.git] / target / linux / Makefile
index 69822879de7ae4554e968fdb6e7f5ca3b4ca3f80..f7bbdffbf831654ca8617277e5fd7aeb8959f416 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+export TARGET_BUILD=1
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-menuconfig: prepare
-       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean
+prereq clean download prepare compile install menuconfig nconfig oldconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@