[adm5120] flash driver shows the correct chip size from now
[openwrt/svn-archive/archive.git] / target / linux / adm5120-2.6 / Makefile
index 69554fe1aeeb2c27a2d8bb5cf9c1b16854e4d5c1..fb46f28312fa2e8289f3dee694e46201bdd71c63 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=adm5120
-BOARDNAME:=ADMtek 5120
-FEATURES:=jffs2 broken
+BOARDNAME:=ADM5120 (Little Endian)
+FEATURES:=squashfs jffs2 pci usb broken
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
-       Build firmware images for ADMTek ADM5120 based boards
-       (e.g : RouterBoard RB112, Compex WP54G ...)
+       Build firmware images for Infineon/ADMtek ADM5120 based boards
+       (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += admswconfig
 
 # include the profiles
 -include profiles/*.mk