simplify and fix adm5120 image building, fix broken FEATURES handling
[openwrt/svn-archive/archive.git] / target / linux / adm5120-2.6 / image / Makefile
index b9ae44ecb41cb1307be0fe90ac7d3e25993cdaa5..802fd956af117dd5e4aadd92a16f89d4c0b802f9 100644 (file)
@@ -86,11 +86,7 @@ define Image/Build/RouterBoard
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
 endef
 
-define Image/Build
-# this line is here intentionally
-ifneq ($(1),jffs2-256k)
-ifneq ($(1),jffs2-128k)
-ifneq ($(1),tgz)
+define Image/Build/jffs2-64k
        $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
 ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
@@ -118,13 +114,21 @@ ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/MyLoader,$(1),wpp54g,$(patsubst jffs2-%,jffs2,$(1)),WPP54G)
        $(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
 endif
-endif
-endif
-endif
-ifeq ($(1),tgz)
+endef
+
+define Image/Build/squashfs
+$(call Image/Build/jffs2-64k,$(1))
+endef
+
+define Image/Build
+$(call Image/Build/$(1),$(1))
+endef
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+  define Image/BuildKernel
        $(call Image/Build/RouterBoard)
+  endef
 endif
-endef
 
 define Image/Build/LZMAKernel
        $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \