[kernel] update to 2.6.27.15
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index ed9dce2c41b83b40ad9b867fa007db46b596ef64..04b47b6b59e39a23888101a9f0f620884167aa7e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-LINUX_VERSION:=2.6.23
-FEATURES:=squashfs jffs2 tgz broken
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.27.15
+SUBTARGETS:=router_le router_be
+INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
-$(eval $(call Target,router_be))
-$(eval $(call Target,router_le))
 $(eval $(call BuildTarget))