brcm63xx: update development kernel to linux 3.14
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index 5a5c5ab155923b05ea7fd9ca42f1366a59591b65..173dad3c6626c8da273ea6fd53aa27af2598a009 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.27.11
-SUBTARGETS:=router_le router_be
+LINUX_VERSION:=3.8.13
+SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
-                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))