kernel: update linux 3.7 to 3.7.3
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index f8436c04ed2e363fe1761903b40876fe1ec327c0..462de16de27016719bdbaebe6d3ab458011c506b 100644 (file)
@@ -1,27 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
-LINUX_VERSION:=2.6.22.4
-
-define Target/Description
-       Build firmware images for Infineon/ADMtek ADM5120 based boards
-       (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=3.7.3
+SUBTARGETS:=router_le router_be rb1xx
+INITRAMFS_EXTRA_FILES:=
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += admswconfig
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))