[adm5120] nfs-101u: add PCI IRQ map for the NEC USB controller (thanks to Daniel...
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index f8436c04ed2e363fe1761903b40876fe1ec327c0..853e0600f74f8494fdd922a3a16fdd21513c5880 100644 (file)
@@ -1,27 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
-LINUX_VERSION:=2.6.22.4
-
-define Target/Description
-       Build firmware images for Infineon/ADMtek ADM5120 based boards
-       (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.27.13
+SUBTARGETS:=router_le router_be
+INITRAMFS_EXTRA_FILES:=
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += admswconfig
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))