[adm5120] switch to 2.6.28
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index 525636c733aa5ef05a56e45fde98338998acbc2b..c8bd1920fe61d9b2b912e185d1816cb5b450c61d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.23.11
-FEATURES:=squashfs jffs2 tgz broken
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.28.9
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 $(eval $(call BuildTarget))