replace the hostapd preselection with a wpad preselection to enable proper client...
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index fcfc8bcbd350dfea486b52bf7d763784c424d403..d7f9f6e60b60ced80de4c6a3b05f4eb8c4cde6dc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.23.1
-FEATURES:=squashfs jffs2 tgz broken
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.30.10
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))