adm5120: create a new subtarget for the RB1xx devices
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / image / router_le.mk
index 7c4bf1d81b18b343b3236ee521fcd64d7cf19b66..6df6dcd8cc10f2880ecaf0db8f56d4ed33491c74 100644 (file)
@@ -399,23 +399,3 @@ define Image/Build/Profile/Generic
 
        $(call Image/Build/Experimental,$(1))
 endef
-
-ifeq ($(PROFILE),RouterBoard)
-  define Image/cmdline/yaffs2
-       root=/dev/mtdblock3 rootfstype=yaffs2
-  endef
-
-  define Image/BuildKernel/RouterBoard
-       $(CP) $(KDIR)/vmlinux.elf $(call imgname,kernel,rb1xx)
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(call imgname,kernel,rb1xx) \
-               '$(strip $(call Image/cmdline/yaffs2))'
-  endef
-
-  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-    define Image/BuildKernel
-       $(call Image/BuildKernel/RouterBoard)
-    endef
-  endif
-
-endif
-