[adm5120] Edimax BR-6104K/KP specific fixes
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / image / router_le.mk
index 9f1aa9b2bee1a94c341dc20a6f39027323ec304e..f9109715999c485a3e0d4bf56085fcc54a45d4ca 100644 (file)
@@ -16,7 +16,11 @@ define Image/Build/Edimax
        $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
                -r $(KDIR)/loader-$(2).gz \
                -x $(call imgname,$(1),$(2)).trx \
-               $(call imgname,$(1),$(2)).bin
+               $(call imgname,$(1),$(2))-webui.bin
+       $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
+               -r $(KDIR)/loader-$(2).gz \
+               -x $(call imgname,$(1),$(2)).trx \
+               $(call imgname,$(1),$(2))-xmodem.bin
 endef
 
 define Image/Build/Infineon
@@ -195,10 +199,6 @@ define Image/Build/Board/BR6104K/squashfs
        $(call Image/Build/Board/BR6104K,squashfs)
 endef
 
-define Image/Build/Board/BR6104K/jffs2-64k
-       $(call Image/Build/Board/BR6104K,jffs2-64k)
-endef
-
 define Image/Build/Board/BR6104K/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 endef
@@ -308,6 +308,10 @@ define Image/Build/Profile/CAS771W
        $(call Image/Build/Board/CAS771W/$(1))
 endef
 
+define Image/Build/Profile/BR6104KP
+       $(call Image/Build/Board/BR6104K/$(1))
+endef
+
 define Image/Build/Profile/RouterBoard
        $(call Image/Build/Board/RB1xx/$(1))
 endef