[adm5120] switch to 2.6.25.7
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / patches / 001-adm5120.patch
index 26c0265049753b47ed49c00b2e57af5ef5839e56..84d0a8d2fc1c8a185b33d09b458f2583882c09e6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -16,6 +16,20 @@
+@@ -18,6 +18,20 @@
        prompt "System type"
        default SGI_IP22
  
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
-@@ -689,6 +703,7 @@
+@@ -683,6 +697,7 @@
  
  endchoice
  
 +source "arch/mips/adm5120/Kconfig"
  source "arch/mips/au1000/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
  source "arch/mips/jazz/Kconfig"
- source "arch/mips/lasat/Kconfig"
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -166,6 +166,16 @@
+@@ -174,6 +174,16 @@
  load-$(CONFIG_MACH_JAZZ)      += 0xffffffff80080000
  
  #
@@ -50,9 +50,9 @@
  core-$(CONFIG_SOC_AU1X00)     += arch/mips/au1000/common/
 --- a/include/asm-mips/bootinfo.h
 +++ b/include/asm-mips/bootinfo.h
-@@ -198,6 +198,58 @@
- #define MACH_GROUP_BRCM               23      /* Broadcom                     */
- #define  MACH_BCM47XX         1       /* Broadcom BCM47XX             */
+@@ -94,6 +94,58 @@
+ #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
+ #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */
  
 +/*
 + * Valid machtype for group ADMtek ADM5120
 +
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
const char *get_system_type(void);
extern char *system_type;