Add hostapd-mini to default images where applicable
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / router_le / profiles / Edimax.mk
index 9b0ca65c2bbeead467ca531242670aa70992057c..70b26534efcf499f5db8ef0ccfe1c63601d8ac44 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,7 @@
 
 define Profile/BR6104K
        NAME:=Edimax BR-6104K (Unofficial)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104K/Description
@@ -15,12 +16,32 @@ endef
 
 define Profile/BR6104KP
        NAME:=Edimax BR-6104KP (Unofficial)
-       PACKAGES:=kmod-usb-core kmod-usb-adm5120
+       PACKAGES:=-hostapd-mini kmod-usb-core kmod-usb-adm5120
 endef
 
 define Profile/BR6104KP/Description
        Package set optimized for the Edimax BR-6104KP
 endef
 
+define Profile/BR6104WG
+       NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
+endef
+
+define Profile/BR6104WG/Description
+       Package set optimized for the Edimax BR-6104Wg
+endef
+
+define Profile/BR6114WG
+       NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
+endef
+
+define Profile/BR6114WG/Description
+       Package set optimized for the Edimax BR-6114WG
+endef
+
 $(eval $(call Profile,BR6104K))
 $(eval $(call Profile,BR6104KP))
+$(eval $(call Profile,BR6104WG))
+$(eval $(call Profile,BR6114WG))