Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a...
[openwrt/svn-archive/archive.git] / target / linux / adm5120eb-2.6 / Makefile
index 7da6e5c3f4bfa3d877a02074c4108034c32984b2..832d269238208a326f4ec45a6021fa9e76ac428a 100644 (file)
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=adm5120eb
-BOARDNAME:=ADMtek 5120 (Big Endian)
-FEATURES:=squashfs broken
+BOARDNAME:=ADM5120 (Big Endian)
+FEATURES:=squashfs pci usb broken
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
-       Build firmware images for ADMTek ADM5120 based boards running in big-endian mode
+       Build firmware images for Infineon/ADMTek ADM5120 based boards running in big-endian mode
        (e.g : ZyXEL Prestige 335WT ...)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += admswconfig
 
 # include the profiles
 -include profiles/*.mk