ar71xx: only allow internal access to the ar7240 switch, export the MDIO bus behind...
[openwrt/svn-archive/archive.git] / target / linux / amazon / Makefile
index 1967d52f42a2febe58017707279cb820b754cccd..aae39a00e91b8c3a4905888992a7e605a66c3550 100644 (file)
@@ -10,16 +10,12 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=2.6.30.10
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
        Build firmware images for Infineon Amazon boards
 endef
 
-KERNELNAME:="uImage"
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))