amazon: update amazon target to kernel 3.3
[openwrt/svn-archive/archive.git] / target / linux / amazon / Makefile
index 1967d52f42a2febe58017707279cb820b754cccd..bfab52e506dffd949dd3f7a1b2f55ca22b066368 100644 (file)
@@ -10,16 +10,18 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=3.3.5
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
        Build firmware images for Infineon Amazon boards
 endef
 
-KERNELNAME:="uImage"
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
+define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mkdir -p $(LINUX_DIR)/arch/mips/include/asm/amazon
+       $(CP) $(LINUX_DIR)/include/asm-mips/amazon/*.h $(LINUX_DIR)/arch/mips/include/asm/amazon
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))