add new ar7 dsl driver (thanks, matteo), mark ar7-2.4 as broken and enable ar7-2.6
[openwrt/svn-archive/archive.git] / target / linux / ar7-2.4 / Makefile
index f9d3290b623851bcd4887121b420abc5ef9bd156..6f705327746cce73ed8000b65044d1253a4bf82f 100644 (file)
@@ -9,35 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs jffs2 broken
 
 define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
 endef
 
 
 define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
 endef
 
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-avalanche-cpmac
 
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-avalanche-cpmac
 
-define Profile/AnnexA
-  NAME:=ADSL Annex A (default)
-  PACKAGES:=kmod-sangam-atm-annex-a ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexA))
-
-define Profile/AnnexB
-  NAME:=ADSL Annex B
-  PACKAGES:=kmod-sangam-atm-annex-b ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexB))
-
-define Profile/None
-  NAME:=No ADSL
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
 
 $(eval $(call BuildKernel))