update to latest 2.6.27 and 2.6.30 kernels
[openwrt/svn-archive/archive.git] / target / linux / ar7 / Makefile
index 0beb8ae75d7644fb2dbe0f7123e128e7133035ea..4e64a06656805b9cb8699f22c6e5897a61bddf3d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,14 +11,15 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.30.7
 
-define Target/Description
-       Build firmware images for TI AR7 based routers
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+               kmod-acx
 
--include profiles/*.mk
+define Target/Description
+       Build firmware images for TI AR7 based routers.
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))