sync for 2.6.23-final
[openwrt/svn-archive/archive.git] / target / linux / ar7 / patches-2.6.22 / 110-flash.patch
index b104067540c7774b9d6bfcc4bb982a29fc6be4f5..6edc353e926a87ef29bdc631483b4e83eea7f31c 100644 (file)
@@ -28,12 +28,13 @@ diff -Nru linux-2.6.19.2/drivers/mtd/Makefile linux-ar7/drivers/mtd/Makefile
 diff -Nru linux-2.6.19.2/drivers/mtd/maps/physmap.c linux-ar7/drivers/mtd/maps/physmap.c
 --- linux-2.6.19.2/drivers/mtd/maps/physmap.c  2006-12-12 02:32:53.000000000 +0700
 +++ linux-ar7/drivers/mtd/maps/physmap.c       2007-02-03 21:57:11.000000000 +0700
-@@ -74,7 +74,7 @@
+@@ -74,7 +74,8 @@
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS
 -static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
-+static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
++static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
++                                      "ar7part", NULL };
  #endif
  
  static int physmap_flash_probe(struct platform_device *dev)